DRMH 200SEK JVC DVD HDD recorder power supply fault

For all discussions regarding JVC DVD recorders.

Moderator: andywilks

Post Reply
ballans
Posts: 4
Joined: Fri Aug 22, 2008 6:52 pm
Location: cambridgeshire

DRMH 200SEK JVC DVD HDD recorder power supply fault

Post by ballans »

I aquired this hdd recorder with a report of a blown fuse. I was going to salvage the 160g hdd but when I opened the machine it all looked in very good condition except for an indication of slight overheating at IC 5101 which had one pin fused. All the capacitors looked good with no leaks or bulges
I decided to try and repair the machine. The following items were clearly defective
IC5101
F5001
R5109
I also replaced C5103,R5107. R5108 tested OK so I did not replace it. I did not have a replacement for the opto coupler PC5101 but I think it is OK?

After replacing these items I powered the machine up and all that happens is that the front panel leds on the HDD and DVD pushbuttons flash at about 2hz. There is also a faint ticking noise from the PSU transformer area.

I noted the following voltages at the positive terminals of the smoothing capacitors
C5307 -- 8.6V
C5308 -- 8.5V
C5306 -- 15.7V
C5305 -- 15.3V
C5304 -- 15.7V
C5303 -- 12.6V

I checked for ripple with a rather doubtful oscilloscope and did not detect significant ripple.

There are zero volts on the 12V and 5v headers for the HDD and the DVD drive.
A circuit diagram of the power supply might be useful but I have now got to the point of wondering if it is worth investing further and should I go back to my origonal aim and just salvage the HDD and forget about the challenge of getting this unit to work.
Has anyone got any ideas as to what I should do next?

User avatar
andywilks
Moderator
Posts: 147
Joined: Mon Jan 24, 2005 11:38 am
Location: Pendle Witch Country, Lancs

Post by andywilks »

Sounds like the psu is firing up then tripping.....continuously.

Did you check and replace if needed the small surface mount resistors on the back of the board? I've had these go high when the main IC fails. watch out for the retained 350v dc on the big cap when working on these.

ballans
Posts: 4
Joined: Fri Aug 22, 2008 6:52 pm
Location: cambridgeshire

Post by ballans »

Andy, thanks for the comments and for all the valuable information on the site.

Your thoughts about the psu tripping sounds possible and I will check the underboard resistors again. I managed to download a JVC service manual from a Russian site today (in english ) so now I have full circuit diagrams and voltages which should make it a lot easier to work on the unit. All I need now is some time to get on with it. I had read your comments before about the 350v on C5003 but I still managed to get quite a belt from it after several days with the power disconnected. At least the capacitor must be in good condition.

I will let you know when I make some progress.

ballans
Posts: 4
Joined: Fri Aug 22, 2008 6:52 pm
Location: cambridgeshire

Post by ballans »

A belated update.

Further test showed that the 45v rail was at zero volts . The 45 volt rectifier D5207 was shorted which had caused the 12v and 5v rails on the same winding to be at low voltage. I replaced D5207 and C5207 and the machine is now working. I wonder if the failure of D5207 could also have caused the STRG6653 to blow?

I found a service manual at
http://rc5.ru/upload/jvc_dvd_DR-MH200SE.pdf

The 40 core HDD FFC cable is slightly damaged and I would like to replace it. Anyone know where I could get one?

WDMDL
Posts: 3
Joined: Mon Jan 26, 2009 8:20 pm

Post by WDMDL »

I had been given a non-working DR-MH200SEK recorder. However, in between the previous owner and myself, someone had removed the HDD and tried it in a PC.
After reading the forum and noting comments about the device firmware being on the HDD, I thought it was doomed. Had they erased or formatted it?
Maybe I was in luck - they didn't know how to get to "Disk management" in XP.

Anyway, the power supply was definitely faulty - a new STRG6653 and a few resistors plus a salvaged optocoupler got it running again.

Next problem was it was now continually flashing "loading".
The flexiprint cable had been damaged by the sharp edge on one of the ferrite beads.
I managed to re-make the end of the cable, but now it was too short to allow the HDD to fit in it's correct position.
Still flashing "loading".
Next, the secondary capacitors were replaced on the power supply.
C5303, C5304, C5305, C5306, C5313, C5316 and C5340.
Interestingly, C5340 as fitted was 470uF/10V, rather than the 22uF/50V shown in the circuit diagram.
There had been no previous work on the power supply.

Success!
It looked like it still wasn't going to boot, but there was a little HDD activity after about a minute, then a lot of HDD activity after nearly 2 minutes.
And then it completed booting and went to standby.

Now it just needs a new flexiprint cable to the HDD.
JVC part number is QUQ105-4038AH-E.
I ordered mine from Partmaster, Their part number is 5045173408289.

Martin.

ballans
Posts: 4
Joined: Fri Aug 22, 2008 6:52 pm
Location: cambridgeshire

Post by ballans »

Thanks Martin for the information on the FFC cable.

However I have replaced my 38cm long FFC cable to the HDD with a standard PC 40 pin IDE cable, a short length of FFC cable and a modification to the existing IDE to FFC adapter to join the two together. It does not look as elegant as the JVC FFC cable but it is a lot cheaper.

I have seen similar 40 pin IDE to 40 pin FFC adapter kits for about £5 on ebay.

On my machine C5340 is 22uf/50V as shown in the circuit diagram.

Also "C5102" and "C5103" text is interchanged on my circuit diagram. The rest of the component description is correct.

Post Reply